<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://dfw.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="myles turner, nba, bedford, texas health, texas health resources, texas health harris methodist hospital hurst-euless-bedford, heb, donation, $50k, coronavirus, covid-19, health, flu guide, basketball, indiana pacers" />
<meta name="keywords" content="myles turner, nba, bedford, texas health, texas health resources, texas health harris methodist hospital hurst-euless-bedford, heb, donation, $50k, coronavirus, covid-19, health, flu guide, basketball, indiana pacers" />
<meta property="fb:pages" content="108571612499317" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources &#8211; CBS Dallas / Fort Worth</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Dallas / Fort Worth &raquo; Feed" href="https://dfw.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Dallas / Fort Worth &raquo; Comments Feed" href="https://dfw.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Dallas / Fort Worth &raquo; NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources Comments Feed" href="https://dfw.cbslocal.com/2020/05/02/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://dfw.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKpSBAvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5RWeGCXKDcMWAGa7IisZrAs6XqXlLOcBMpmPat3cFPEAaDbmVjQhLtvsOR6uw5QxBXqW3026DV7XA/UEGznjF1mw9FtZBLkbjhpdWjBsPakyLPy/9TIbWJS//3Gi7DdBrG4+E8Tk91nZ9e' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://dfw.cbslocal.com/_static/??-eJyNy0sKgDAMANELWWPFUlyIZ6kxqJB+IBHx9toLiNvhDVzFYE5KSUF3iiSAixjOGBhEb6YWRRr4YkdCPteaRKCEjYxSLBz0x1sX4jcmlarnOFnnh27snbcPIdU5HQ==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://dfw.cbslocal.com/_static/??-eJydktFygyAQRX+ohEmaOr50+i0LbgwVXAbWWP++EGMyqZ1WfXDmuuy53AVk74WmlrFlyWd0GKVWUVjSYKW3XW3aKB1VnU0r1wbhoIUag9QxVQaPx11SL/IvI9Nq21W5lJjeVCgYnbfAGFfCHgIvYH4mj2cKrGlyefyu2B6dwmrkr1JYE1loYLBUrxwjTWG0RXGZH94UPX0MdQAnTojVGFuJR/UgDjtn2jv/5F+laFKljZuUUgUIg4w8WHwiFp9eurEa+X57Wc9MXCcm7BPZg25m+Ak0KqIcqUni6xZpgxOTF55iUr9bbHjJDkKTrcd+TZbChnf2ny9dMPTB8KKpM37Tuf3Dve/fynJfFsVr8Q3AmWZy' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://dfw.cbslocal.com/_static/??-eJy1kNEOwiAMRX9IRqZx2YvxWxhU7CxljqLx78XFB/fkZuJTodx7eqm+D8pGFmDRcoYASdsuKYrWkEa2lF1p9UkPkR4nJKoCctWnjV5q7Bc5BsoeOekQXabyYtxkLkXdtp+EGfqaYXy8y1eBCuhHI/BTnkmggmHjYXyhZw1V5l0kDqsWc8psBSOnfwQCKjeWtCqRcWdIeFu2oaL3FDtD60aMgpZg9Xfv6DzIhHgfC+IYDvW+beu2aXZN/wR2QgqF'></script>
<link rel='https://api.w.org/' href='https://dfw.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dfw.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dfw.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://cbsloc.al/3de5KQR' />
<link rel="alternate" type="application/json+oembed" href="https://dfw.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdfw.cbslocal.com%2F2020%2F05%2F02%2Fnba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dfw.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdfw.cbslocal.com%2F2020%2F05%2F02%2Fnba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources" /><meta property="og:image" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/08/gettyimages-503035234.jpg?w=1500" /><meta property="og:image:secure_url" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/08/gettyimages-503035234.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="1000" /><meta property="og:description" content="The donation comes after the Indiana Pacer&#039;s father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford." /><meta property="og:type" content="article" /><meta property="og:url" content="https://dfw.cbslocal.com/2020/05/02/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources/" /><meta property="article:published_time" content="2020-05-02T16:30:42+00:00" /><meta property="article:suggested-social-copy" content="The donation comes after the Indiana Pacer&#039;s father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Flu Guide,Local,News,Syndicated Local" /><meta property="article:publisher" content="https://www.facebook.com/CBSDFW" /><meta property="article:author" content="https://www.facebook.com/CBSDFW" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/08/gettyimages-503035234.jpg?w=1500"><meta name="twitter:title" content="NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources"/><meta name="twitter:description" content="The donation comes after the Indiana Pacer&#039;s father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford."/><meta name="twitter:site" content="CBSDFW"/>
<link rel="canonical" href="https://dfw.cbslocal.com/2020/05/02/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://dfw.cbslocal.com/2020/05/02/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/dfw.cbslocal.com","url":"https:\/\/dfw.cbslocal.com","name":"CBS Dallas \/ Fort Worth","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"https:\/\/cbsdfw.com","logo":{"@type":"ImageObject","url":"https:\/\/dfw.cbslocal.com\/wp-content\/uploads\/sites\/15909545\/2018\/05\/4_dallas_cbs11_txa21.png?w=262"}},"url":"https:\/\/dfw.cbslocal.com\/2020\/05\/02\/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/dfw.cbslocal.com\/2020\/05\/02\/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources\/"},"headline":"NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources","description":"The donation comes after the Indiana Pacer's father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford.","image":"https:\/\/dfw.cbslocal.com\/wp-content\/uploads\/sites\/15909545\/2016\/08\/gettyimages-503035234.jpg?w=150","keywords":["Flu Guide","Local","News","Syndicated Local","$50k","Basketball","Bedford","Coronavirus","Covid-19","donation","flu guide","Health","HEB","Indiana Pacers","Myles Turner","NBA","Texas Health","Texas Health Harris Methodist Hospital Hurst-Euless-Bedford","Texas Health Resources","news","NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources"],"datePublished":"2020-05-02T16:30:42+00:00","dateModified":"2020-05-02T16:30:42+00:00","author":{"@type":"Organization","name":"CBS Dallas\/Fort Worth"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"CBS 11 News Now: Friday Evening","description":"CBS 11 News Now: Friday Evening","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/87A\/2BB\/87A2BB2E584A42509740A762B77D8C0E.jpg?Expires=1683072000&KeyName=mcpkey1&Signature=377XznefjYQl8evVFLj95SMVhIE","uploadDate":"2020-05-01","duration":"T2M45S","contentUrl":"https:\/\/dfw.cbslocal.com\/video\/4535483-cbs-11-news-now-friday-evening\/","embedUrl":"https:\/\/dfw.cbslocal.com\/video\/4535483-cbs-11-news-now-friday-evening\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.DALLAS","news",["nbastarbedfordnativemylesturnerdonates50ktotexashealthresources","post","article","fluguide","local","news","syndicatedlocal","50k","basketball","bedford","coronavirus","covid19","donation","health","heb","indianapacers","mylesturner","nba","texashealth","texashealthharrismethodisthospitalhursteulessbedford","texashealthresources","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"flu-guide;local;news;syndicated-local;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 9px;
}

.postid-876710 #reptile_30_wrapper {
	display:none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The donation comes after the Indiana Pacer&#039;s father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford." />
<script>//<![CDATA[
//]]></script>

</head>

<body class="post-template-default single single-post postid-907181 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://dfw.cbslocal.com" id="header-logo"><img src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2018/05/4_dallas_cbs11_txa21.png?w=262" alt="CBS Dallas / Fort Worth" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/sports/cowboys/" title="Cowboys" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Cowboys</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/texas-rangers/" title="Rangers" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rangers</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/mavericks/" title="Mavericks" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Mavericks</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/stars/" title="Stars" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Stars</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/fc-dallas/" title="FC Dallas" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">FC Dallas</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/wings/" title="Wings" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Wings</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/golf-sports/" title="Golf" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Golf</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/tennis/" title="Tennis" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Tennis</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/nascar/" title="NASCAR" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NASCAR</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/ufc/" title="UFC" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">UFC</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/college-sports/" title="College Sports" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">College Sports</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/high-school-sports/" title="High School Sports" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">High School Sports</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/video/">Video</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/4535709-scott-padgetts-weekend-weather-forecast/" title="Scott Padgett&#039;s Weekend Weather Forecast" class="cbs-thumbnail-link item-1588389828 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/EF9/15D/EF915D020F504102A4C179D31180AB7C.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=a_xAI-MKsXvpc0Y08t7y6eVuBI4"></span></div><div class="title-wrapper"><strong class="title">Scott Padgett&#039;s Weekend Weather Forecast</strong><em class="description">A gorgeous weekend is in store for North Texas this weekend with sunny skies and temperatures in the low 90s.</em></div><time datetime="2020-05-02T03:23:48+00:00" title="May 1, 2020 at 10:23 pm">18 hours ago</time></a><a href="https://dfw.cbslocal.com/video/4535708-2020-graduates-friday-may-1-10pm-newscast/" title="2020 Graduates: Friday, May 1 10pm Newscast" class="cbs-thumbnail-link item-1588389826 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/FF3/EAF/FF3EAF8915E8458198D2EFD628E099E7.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=tUEa0Ohosj9ZJEBay4WfazH1kCQ"></span></div><div class="title-wrapper"><strong class="title">2020 Graduates: Friday, May 1 10pm Newscast</strong><em class="description">2020 Graduates: Friday, May 1 10pm Newscast</em></div><time datetime="2020-05-02T03:23:46+00:00" title="May 1, 2020 at 10:23 pm">18 hours ago</time></a><a href="https://dfw.cbslocal.com/video/4535705-north-texas-school-district-recognizing-alumni-on-front-lines-of-covid-19-outbreak/" title="North Texas School District Recognizing Alumni On Front Lines Of COVID-19 Outbreak" class="cbs-thumbnail-link item-1588389727 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/371/D8D/371D8D06D83D4038A4193F8EDF93319C.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=Ix6KdISFMOMHt_2MYPBkUnFvfAM"></span></div><div class="title-wrapper"><strong class="title">North Texas School District Recognizing Alumni On Front Lines Of COVID-19 Outbreak</strong><em class="description">Former Allen High School students who are now doctors and nurses are being honored for their efforts during the coronavirus pandemic.</em></div><time datetime="2020-05-02T03:22:07+00:00" title="May 1, 2020 at 10:22 pm">18 hours ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="https://dfw.cbslocal.com/category/politics/" title="Politics" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://dfw.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://dfw.cbslocal.com/category/news/consumer/" title="Consumer" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Consumer</strong></div></a><a href="https://dfw.cbslocal.com/category/news/education/" title="Education" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Education</strong></div></a><a href="https://dfw.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://dfw.cbslocal.com/category/news/tech/" title="Tech" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Tech</strong></div></a><a href="https://dfw.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://dfw.cbslocal.com/category/autos" title="Autos" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Autos</strong></div></a><a href="https://dfw.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/05/02/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources/" title="NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources" class="cbs-thumbnail-link item-1588455042 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/08/gettyimages-503035234.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources</strong><em class="description">The donation comes after the Indiana Pacer&#039;s father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford.</em></div></a><a href="https://dfw.cbslocal.com/2020/05/02/irving-man-in-his-20s-among-4-new-coronavirus-deaths-in-dallas-county/" title="Irving Man In His 20s Among 4 New Coronavirus Deaths In Dallas County" class="cbs-thumbnail-link item-1588450520 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/GettyImages-1218637518.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Irving Man In His 20s Among 4 New Coronavirus Deaths In Dallas County</strong><em class="description">As of 11 a.m. May 2, Dallas County has 181 additional positive cases COVID-19, bringing the county&#039;s total case count to 3,899, including 110 deaths.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Featured Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/video/category/news/" title="News Video" class="cbs-thumbnail-link item-1479855909" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_news_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News Video</strong></div></a><a href="http://dfw.cbslocal.com/video/category/news-weather/" title="Weather Video" class="cbs-thumbnail-link item-1479855854" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Video</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/weather/" title="DFW Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">DFW Weather</strong></div></a><a href="https://dfw.cbslocal.com/100-mile-radius/" title="Live Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Radar</strong></div></a><a href="http://apps.cbslocal.com/weather/dfw/" title="Weather App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a><a href="https://dfw.cbslocal.com/school-closings/" title="Closings/Cancellations" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Closings/Cancellations</strong></div></a><a href="https://dfw.cbslocal.com/cbs-11-storm-chaser/" title="Mobile 11" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Mobile 11</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Forecast</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/4535709-scott-padgetts-weekend-weather-forecast/" title="Scott Padgett&#039;s Weekend Weather Forecast" class="cbs-thumbnail-link item-1588389828 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/EF9/15D/EF915D020F504102A4C179D31180AB7C.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=a_xAI-MKsXvpc0Y08t7y6eVuBI4"></span></div><div class="title-wrapper"><strong class="title">Scott Padgett&#039;s Weekend Weather Forecast</strong><em class="description">A gorgeous weekend is in store for North Texas this weekend with sunny skies and temperatures in the low 90s.</em></div><time datetime="2020-05-02T03:23:48+00:00" title="May 1, 2020 at 10:23 pm">18 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Stories</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/04/29/investigators-say-lightning-sparked-3-house-fires-overnight-in-less-than-2-hours/" title="Investigators Say Lightning Sparked 3 House Fires Overnight In Less Than 2 Hours" class="cbs-thumbnail-link item-1588181586 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/GettyImages-90714829.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Investigators Say Lightning Sparked 3 House Fires Overnight In Less Than 2 Hours</strong><em class="description">Fire investigators said they believe lightning caused three overnight house fires that happened within less than a couple of hours of each other overnight in Frisco.</em></div></a><a href="https://dfw.cbslocal.com/2020/04/29/line-of-storms-south-damage-north-texas/" title="Line Of Storms Move To The South After Causing Damage Across North Texas Overnight" class="cbs-thumbnail-link item-1588160365 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/Johnson-County-EM-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Line Of Storms Move To The South After Causing Damage Across North Texas Overnight</strong><em class="description">The metroplex was spared the worst of the storms on Tuesday night, but some North Texans were hit with multiple rounds of severe weather.</em></div></a><a href="https://dfw.cbslocal.com/2020/04/28/morning-hail-evening-storms-near-hurricane-force-winds-dfw/" title="After Morning Hail, Evening Storms Expected To Bring Near Hurricane-Force Winds To DFW" class="cbs-thumbnail-link item-1588079168 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/Tuesday-hail.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">After Morning Hail, Evening Storms Expected To Bring Near Hurricane-Force Winds To DFW</strong><em class="description">As morning severe weather ends, the focus turns to the late evening and overnight hours. That&#039;s when a cold front will push into North Texas and bring severe weather.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/">All Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/sports/cowboys/" title="Cowboys" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Cowboys</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/texas-rangers/" title="Rangers" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rangers</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/mavericks/" title="Mavericks" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Mavericks</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/stars/" title="Stars" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Stars</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/fc-dallas/" title="FC Dallas" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">FC Dallas</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/wings/" title="Wings" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Wings</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/golf-sports/" title="Golf" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Golf</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/tennis/" title="Tennis" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Tennis</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/nascar/" title="NASCAR" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NASCAR</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/ufc/" title="UFC" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">UFC</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/college-sports/" title="College Sports" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">College Sports</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/high-school-sports/" title="High School Sports" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">High School Sports</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/cowboys/">Cowboys</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/04/30/former-tcu-tailback-plans-to-make-dallas-cowboys-team-as-undrafted-free-agent/" title="Former TCU Tailback Sewo Olonilua Plans To Make Cowboys Team As Free Agent" class="cbs-thumbnail-link item-1588287461 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2017/10/gettyimages-858747726-e1510861280117.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Former TCU Tailback Sewo Olonilua Plans To Make Cowboys Team As Free Agent</strong><em class="description">With the coronavirus outbreak leaving the NFL season in limbo, Olonilua said he wants to stay ready to make his dreams come true.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/texas-rangers/">Rangers</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/04/29/texas-rangers-fans-tickets-games-not-played-refunds/" title="Some Rangers Fans Who Bought Tickets To Games Not Played Anxiously Await Refunds" class="cbs-thumbnail-link item-1588199934 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/03/Screen-Shot-2020-03-05-at-7.07.10-PM.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Some Rangers Fans Who Bought Tickets To Games Not Played Anxiously Await Refunds</strong><em class="description">The Texas Rangers would have played their 30th game of the season this week. But there are no games happening at Globe Life Field.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/mavericks/">Mavericks</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/04/07/mark-cuban-says-nba-return-may-not-be-in-front-of-fans/" title="Mark Cuban Says NBA Return &quot;May Not Be In Front Of Fans&quot;" class="cbs-thumbnail-link item-1586280996 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/03/GettyImages-1158140219.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Mark Cuban Says NBA Return &quot;May Not Be In Front Of Fans&quot;</strong><em class="description">Dallas Mavericks owner Mark Cuban responded to President Trump&#039;s comments about when sports would return in the United States.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/stars/">Stars</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/03/25/report-dallas-stars-gm-jim-nill-ceo-jim-lites-take-50-pay-cut/" title="Report: Dallas Stars GM Jim NIll &amp; CEO Jim Lites Take 50% Pay Cut" class="cbs-thumbnail-link item-1585171399 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2017/02/gettyimages-542852372.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Report: Dallas Stars GM Jim NIll &amp; CEO Jim Lites Take 50% Pay Cut</strong><em class="description">The Dallas Stars general manager Jim Nill and CEO Jim Lites have taken a 50% pay cut to help lessen the financial stress on the team. According to the reports, the cuts are retroactive to the start of the NHL suspension caused by the Coronavirus outbreak on March 12th.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://dfw.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Featured Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/video/category/news/" title="News Video" class="cbs-thumbnail-link item-1479855909" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_news_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News Video</strong></div></a><a href="http://dfw.cbslocal.com/video/category/news-weather/" title="Weather Video" class="cbs-thumbnail-link item-1479855854" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Video</strong></div></a><a href="http://dfw.cbslocal.com/video/category/sports/" title="Sports" class="cbs-thumbnail-link item-1479769606" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/03/category_sports_2_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sports</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/4535709-scott-padgetts-weekend-weather-forecast/" title="Scott Padgett&#039;s Weekend Weather Forecast" class="cbs-thumbnail-link item-1588389828 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/EF9/15D/EF915D020F504102A4C179D31180AB7C.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=a_xAI-MKsXvpc0Y08t7y6eVuBI4"></span></div><div class="title-wrapper"><strong class="title">Scott Padgett&#039;s Weekend Weather Forecast</strong><em class="description">A gorgeous weekend is in store for North Texas this weekend with sunny skies and temperatures in the low 90s.</em></div><time datetime="2020-05-02T03:23:48+00:00" title="May 1, 2020 at 10:23 pm">18 hours ago</time></a><a href="https://dfw.cbslocal.com/video/4535705-north-texas-school-district-recognizing-alumni-on-front-lines-of-covid-19-outbreak/" title="North Texas School District Recognizing Alumni On Front Lines Of COVID-19 Outbreak" class="cbs-thumbnail-link item-1588389727 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/371/D8D/371D8D06D83D4038A4193F8EDF93319C.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=Ix6KdISFMOMHt_2MYPBkUnFvfAM"></span></div><div class="title-wrapper"><strong class="title">North Texas School District Recognizing Alumni On Front Lines Of COVID-19 Outbreak</strong><em class="description">Former Allen High School students who are now doctors and nurses are being honored for their efforts during the coronavirus pandemic.</em></div><time datetime="2020-05-02T03:22:07+00:00" title="May 1, 2020 at 10:22 pm">18 hours ago</time></a><a href="https://dfw.cbslocal.com/video/4535697-blue-bell-pleads-guilty-in-ice-cream-listeria-case-former-ceo-charged/" title="Blue Bell Pleads Guilty In Ice Cream Listeria Case, Former CEO Charged" class="cbs-thumbnail-link item-1588389479 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/49E/D97/49ED9752386C4727B6961330E5EE65CD.jpg?Expires=1683072000&#038;KeyName=mcpkey1&#038;Signature=NnpRFnOAkje8FFQ7h6REadpKGbQ"></span></div><div class="title-wrapper"><strong class="title">Blue Bell Pleads Guilty In Ice Cream Listeria Case, Former CEO Charged</strong><em class="description">Blue Bell agreed to pay more than $19 million in fines and forfeiture as part of a plea agreement on two misdemeanor counts for shipping contaminated ice cream.</em></div><time datetime="2020-05-02T03:17:59+00:00" title="May 1, 2020 at 10:17 pm">18 hours ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/04/16/order-in-stay-safe-and-support-local-spots/" title="Order In, Stay Safe and Support Local Spots!" class="cbs-thumbnail-link item-1587062708 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/ESP-QUARANTINE-THUMB.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Order In, Stay Safe and Support Local Spots!</strong></div></a><a href="https://dfw.cbslocal.com/2020/03/19/changing-the-world-one-sandwich-at-a-time/" title="Changing the World, One Sandwich at a Time." class="cbs-thumbnail-link item-1584653503 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/03/ESP-PSC-THUMB.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Changing the World, One Sandwich at a Time.</strong></div></a><a href="https://dfw.cbslocal.com/2019/10/02/step-right-up-to-lone-star-circus-school/" title="Step Right Up to Lone Star Circus School" class="cbs-thumbnail-link item-1570058001 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/10/Screen-Shot-2019-10-02-at-1.50.12-PM-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Step Right Up to Lone Star Circus School</strong></div></a><a href="https://dfw.cbslocal.com/2019/09/19/sweet-treat-lessons-at-funkytown-donuts/" title="Sweet Treat Lessons at Funkytown Donuts" class="cbs-thumbnail-link item-1568918584 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/09/taryn-donuts.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sweet Treat Lessons at Funkytown Donuts</strong></div></a><a href="https://dfw.cbslocal.com/2019/05/28/six-flags-over-texas-el-diablo-tallest-loop-coaster/" title="Six Flags Over Texas Debuts &#039;El Diablo&#039; The World’s Tallest Loop Coaster" class="cbs-thumbnail-link item-1559049244 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/05/el-diablo.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Six Flags Over Texas Debuts &#039;El Diablo&#039; The World’s Tallest Loop Coaster</strong><em class="description">We hear it&#039;s a devil of a ride! El Diablo, the 14th loop coaster at Six Flags Over Texas, opens to the public today.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/video/program/1163/">E.S.P. Videos</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/video/program/1163/" title="Eat.See.Play Video" class="cbs-thumbnail-link item-1435727055" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2015/07/cadillac-esp_generic_310x174.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Eat.See.Play Video</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/uncategorized/station-contests/" title="Contests &amp; More" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/station/cbs-11/" title="CBS 11 / News Team" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBS 11 / News Team</strong></div></a><a href="https://dfw.cbslocal.com/station/txa-21/" title="TXA 21" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">TXA 21</strong></div></a><a href="https://dfw.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://dfw.cbslocal.com/category/links-numbers/" title="Links &amp; Numbers" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Links &amp; Numbers</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Upload Images/Video" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Upload Images/Video</strong></div></a><a href="https://dfw.cbslocal.com/photo-galleries/" title="Photo Galleries" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Photo Galleries</strong></div></a><a href="https://dfw.cbslocal.com/category/uncategorized/station-contests/" title="Contests" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contests</strong></div></a><a href="https://dfw.cbslocal.com/category/uncategorized/station-events/" title="Station Events" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Station Events</strong></div></a><a href="https://dfw.cbslocal.com/category/cares/" title="Community Events" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Community Events</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/dfw-outdoorsman/">DFW Outdoorsman</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/program/694/" title="Video" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><a href="https://dfw.cbslocal.com/outfitters/" title="Outfitters" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Outfitters</strong></div></a><a href="https://dfw.cbslocal.com/piece-of-texas/" title="Financing Your Piece of Texas" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Financing Your Piece of Texas</strong></div></a><a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Share Photos" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/04/30/american-airlines-require-passengers-wear-masks-coronavirus-pandemic/" title="American Airlines To Require Passengers To Wear Masks During Coronavirus Pandemic" class="cbs-thumbnail-link item-1588283422 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/03/gettyimages-1129867753-e1552359512786.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">American Airlines To Require Passengers To Wear Masks During Coronavirus Pandemic</strong><em class="description">Face coverings are already required for flight attendants during every mainline and regional flight effective Friday, May 1.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/cbs-11-storm-chaser/" title="CBS 11 Storm Chaser" class="cbs-thumbnail-link item-1525296685" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2018/05/unknown2.jpeg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS 11 Storm Chaser</strong></div></a><a href="http://dfw.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519414047" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/cbs-11-live-video/" title="CBS 11 News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS 11 News</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">2:00 PM</strong><em class="description">PGA TOUR Golf</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">DFW Outdoorsman</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">5:30 PM</strong><em class="description">CBS Weekend News</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">6:00 PM</strong><em class="description">CBS 11 News at 6pm</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">6:30 PM</strong><em class="description">Wheel of Fortune</em></div></div></div>
</div></div><a class="view-all" href="http://dallas.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://dfw.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="32.899809" longitude="-97.040335" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://dfw.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">NBA Star, Bedford-Native Myles Turner Donates $50K To Texas Health Resources</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">May 2, 2020 at 4:30 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://dfw.cbslocal.com/tag/50k/">$50k</a>, <a href="https://dfw.cbslocal.com/tag/basketball/">Basketball</a>, <a href="https://dfw.cbslocal.com/tag/bedford/">Bedford</a>, <a href="https://dfw.cbslocal.com/tag/coronavirus-2/">Coronavirus</a>, <a href="https://dfw.cbslocal.com/tag/covid-19/">Covid-19</a>, <a href="https://dfw.cbslocal.com/tag/donation/">donation</a>, <a href="https://dfw.cbslocal.com/tag/flu-guide/">flu guide</a>, <a href="https://dfw.cbslocal.com/tag/health/">Health</a>, <a href="https://dfw.cbslocal.com/tag/heb/">HEB</a>, <a href="https://dfw.cbslocal.com/tag/indiana-pacers/">Indiana Pacers</a>, <a href="https://dfw.cbslocal.com/tag/myles-turner/">Myles Turner</a>, <a href="https://dfw.cbslocal.com/tag/nba/">NBA</a>, <a href="https://dfw.cbslocal.com/tag/texas-health/">Texas Health</a>, <a href="https://dfw.cbslocal.com/tag/texas-health-harris-methodist-hospital-hurst-euless-bedford/">Texas Health Harris Methodist Hospital Hurst-Euless-Bedford</a>, <a href="https://dfw.cbslocal.com/tag/texas-health-resources/">Texas Health Resources</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script type="text/plain" class="optanon-category-4" async data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4535483&quot;,&quot;autoplay&quot;:true,&quot;accessKey&quot;:&quot;5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Dallas.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;https:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.DALLAS&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=https:\/\/dfw.cbslocal.com&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/3de5KQR&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5,&quot;recom&quot;:true,&quot;maxRecomPages&quot;:3}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><br />
<html><body><strong>BEDFORD, Texas (CBSDFW.COM) &mdash; </strong>NBA star and Bedford-native Myles Turner has made a $50,000 donation to Texas Health Resources.</p>
<p>The donation comes after the Indiana Pacer&#8217;s father was successfully treated for COVID-19 at Texas Health Harris Methodist Hospital Hurst-Euless-Bedford.</p>
<p>So far, Tarrant County has seen&nbsp;71 confirmed deaths from COVID-19 and 583 recoveries.</p>
<p>And although stay-at-home requirements have been allowed to expire, Tarrant County Health Director Vinny Taneja encouraged residents to continue to stay home as much as possible and follow the public health guidelines:</p>
<ul>
<li><strong>If you do go out, cover your mouth and nose with a mask or scarf.</strong></li>
<li><strong>Practice social distancing &#8211; stay six feet away from others when you are out.</strong></li>
<li><strong>Wash your hands often with soap and water for at least 20 seconds. If soap and water are not available, use an alcohol-based hand sanitizer.</strong></li>
<li><strong>Don&rsquo;t touch your eyes, nose and mouth with unwashed hands.</strong></li>
<li><strong>Avoid contact with people who are sick.</strong></li>
<li><strong>If you have difficulty breathing, or a persistent fever, call your doctor or healthcare provider.</strong></li>
<li><strong>Cover your cough or sneeze with a tissue or your sleeve.</strong></li>
<li><strong>Frequently clean and disinfect touched objects and surfaces.</strong></li>
</ul>
<p>COVID-19 causes respiratory illness with cough, fever and shortness of breath, and may lead to bronchitis and severe pneumonia.</p>
<p>For more information, go to <a href="http://coronavirus.tarrantcounty.com" rel="nofollow">coronavirus.tarrantcounty.com</a> or call the TCPH information line at 817-248-6299.</body></html></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3de5KQR"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3de5KQR"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3de5KQR"></a></span>
			</div>
		
			</div>
</div></div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/05/02/nba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=162246146&#038;postid=907181&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.4.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=a354dff303bfb560c498b3df450ff37198ea7a17#parent=https%3A%2F%2Fdfw.cbslocal.com%2F2020%2F05%2F02%2Fnba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

					
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSDFW" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/#!/CBSDFW" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="https://www.youtube.com/user/CBSDFW/videos" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.instagram.com/CBSDFW/" target="_blank" title="instagram_url" class="cbs-thumbnail-link instagram_url" ><div class="title-wrapper"><strong class="title">instagram_url</strong></div></a><a href="https://www.reddit.com/user/cbs11dfw/" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/ktvt-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=dfw"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/lewisville-isd-graduation-texas-motor-speedway/" title="Texas Motor Speedway To Host 2020 Graduation Ceremonies For All Denton County Schools" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/GettyImages-666231854.jpg?resize=55%2C55&#038;ssl=1" alt="Texas Motor Speedway To Host 2020 Graduation Ceremonies For All Denton County Schools" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/lewisville-isd-graduation-texas-motor-speedway/" title="Texas Motor Speedway To Host 2020 Graduation Ceremonies For All Denton County Schools" class="bump-view" data-bump-view="tp">Texas Motor Speedway To Host 2020 Graduation Ceremonies For All Denton County Schools</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/3-family-members-died-crash-dallas-identified/" title="3 Family Members Who Died Thursday After Crash In Dallas Identified" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/261990C116EA4D8E9803BDD7B8460EB0.jpg?resize=55%2C55&#038;ssl=1" alt="3 Family Members Who Died Thursday After Crash In Dallas Identified" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/3-family-members-died-crash-dallas-identified/" title="3 Family Members Who Died Thursday After Crash In Dallas Identified" class="bump-view" data-bump-view="tp">3 Family Members Who Died Thursday After Crash In Dallas Identified</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/04/30/texas-coronavirus-deaths-hit-single-day-high-on-eve-of-reopening/" title="Texas Coronavirus Deaths Hit Single-Day High On Eve Of Reopening; Deaths Lagging Indicator" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/GettyImages-1205340830.jpg?resize=55%2C55&#038;ssl=1" alt="Texas Coronavirus Deaths Hit Single-Day High On Eve Of Reopening; Deaths Lagging Indicator" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/04/30/texas-coronavirus-deaths-hit-single-day-high-on-eve-of-reopening/" title="Texas Coronavirus Deaths Hit Single-Day High On Eve Of Reopening; Deaths Lagging Indicator" class="bump-view" data-bump-view="tp">Texas Coronavirus Deaths Hit Single-Day High On Eve Of Reopening; Deaths Lagging Indicator</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/dallas-county-reports-record-high-coronavirus-diagnoses-as-businesses-reopen/" title="Dallas County Reports Record High Coronavirus Diagnoses As Businesses Reopen" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/03/GettyImages-1204866804.jpg?resize=55%2C55&#038;ssl=1" alt="Dallas County Reports Record High Coronavirus Diagnoses As Businesses Reopen" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/dallas-county-reports-record-high-coronavirus-diagnoses-as-businesses-reopen/" title="Dallas County Reports Record High Coronavirus Diagnoses As Businesses Reopen" class="bump-view" data-bump-view="tp">Dallas County Reports Record High Coronavirus Diagnoses As Businesses Reopen</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/texas-amber-alert-2-year-old-aurora-lee-lopez-san-antonio/" title="Texas Amber Alert: Missing San Antonio Child Found Safe Near Waco" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/p61078-e1588334821880.jpg?resize=55%2C55&#038;ssl=1" alt="Texas Amber Alert: Missing San Antonio Child Found Safe Near Waco" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/texas-amber-alert-2-year-old-aurora-lee-lopez-san-antonio/" title="Texas Amber Alert: Missing San Antonio Child Found Safe Near Waco" class="bump-view" data-bump-view="tp">Texas Amber Alert: Missing San Antonio Child Found Safe Near Waco</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/what-you-need-to-know-about-businesses-reopening-north-texas-friday/" title="What You Need To Know About Businesses Reopening In North Texas Today" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/1E7319BDBFF94BEDA3C2EC44688D3A13.jpg?resize=55%2C55&#038;ssl=1" alt="What You Need To Know About Businesses Reopening In North Texas Today" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/what-you-need-to-know-about-businesses-reopening-north-texas-friday/" title="What You Need To Know About Businesses Reopening In North Texas Today" class="bump-view" data-bump-view="tp">What You Need To Know About Businesses Reopening In North Texas Today</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/teen-arrested-charged-with-capital-murder-in-connection-to-womans-death/" title="Teen Arrested, Charged With Capital Murder In Connection To Woman&#039;s Death" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/Web-Roel-Jose-Cano-Jr.jpg?resize=55%2C55&#038;ssl=1" alt="Teen Arrested, Charged With Capital Murder In Connection To Woman&#039;s Death" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/teen-arrested-charged-with-capital-murder-in-connection-to-womans-death/" title="Teen Arrested, Charged With Capital Murder In Connection To Woman&#039;s Death" class="bump-view" data-bump-view="tp">Teen Arrested, Charged With Capital Murder In Connection To Woman&#039;s Death</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/dallas-restaurants-reopen-less-booming-business/" title="Dallas Area Restaurants Reopen To Less Than Booming Business: &#039;It&#039;s So New Just Starting Out&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/image1.jpeg?resize=55%2C55&#038;ssl=1" alt="Dallas Area Restaurants Reopen To Less Than Booming Business: &#039;It&#039;s So New Just Starting Out&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/dallas-restaurants-reopen-less-booming-business/" title="Dallas Area Restaurants Reopen To Less Than Booming Business: &#039;It&#039;s So New Just Starting Out&#039;" class="bump-view" data-bump-view="tp">Dallas Area Restaurants Reopen To Less Than Booming Business: &#039;It&#039;s So New Just Starting Out&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/04/30/essential-workers-more-than-half-dallas-countys-hospitalized-coronavirus-cases/" title="&#039;Essential&#039; Workers Account For More Than Half Of Dallas County&#039;s Hospitalized Coronavirus Cases" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/F350F198A6DA49789651FCCADACC7353.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Essential&#039; Workers Account For More Than Half Of Dallas County&#039;s Hospitalized Coronavirus Cases" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/04/30/essential-workers-more-than-half-dallas-countys-hospitalized-coronavirus-cases/" title="&#039;Essential&#039; Workers Account For More Than Half Of Dallas County&#039;s Hospitalized Coronavirus Cases" class="bump-view" data-bump-view="tp">&#039;Essential&#039; Workers Account For More Than Half Of Dallas County&#039;s Hospitalized Coronavirus Cases</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2020/05/01/dallas-restaurant-owner-has-emotional-first-day-back-open-for-business/" title="Dallas Restaurant Owner Has Emotional First Day Back Open For Business" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/Screen-Shot-2020-05-01-at-10.05.53-PM.png?resize=55%2C55&#038;ssl=1" alt="Dallas Restaurant Owner Has Emotional First Day Back Open For Business" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2020/05/01/dallas-restaurant-owner-has-emotional-first-day-back-open-for-business/" title="Dallas Restaurant Owner Has Emotional First Day Back Open For Business" class="bump-view" data-bump-view="tp">Dallas Restaurant Owner Has Emotional First Day Back Open For Business</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://dfw.cbslocal.com" class="logo"><img src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2017/10/dfw.png" alt="CBS Dallas / Fort Worth" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSDFW" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/#!/CBSDFW" class="twitter" target="_blank">Twitter</a><a href="https://www.youtube.com/user/CBSDFW/videos" class="youtube" target="_blank">YouTube</a><a href="https://www.instagram.com/CBSDFW/" class="instagram" target="_blank">Instagram</a><a href="https://www.reddit.com/user/cbs11dfw/" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/ktvt-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/news/" title="Dallas News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Dallas News</strong></div></a><a href="https://dfw.cbslocal.com/tag/dfw-news/" title="DFW News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">DFW News</strong></div></a><a href="https://dfw.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><a href="https://dfw.cbslocal.com/photo-galleries/" title="Photo Galleries" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Photo Galleries</strong></div></a><a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Share Photos" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a><a href="https://dfw.cbslocal.com/category/links-numbers/" title="Links &amp; Numbers" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Links &amp; Numbers</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/sports/" title="Dallas Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Dallas Sports</strong></div></a><a href="https://sports.cbslocal.com" title="CBS Local Sports" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBS Local Sports</strong></div></a><a href="https://dfw.cbslocal.com/the-landry-award/" title="The Landry Award" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">The Landry Award</strong></div></a><a href="https://dfw.cbslocal.com/category/dfw-outdoorsman/" title="DFW Outdoorsman" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">DFW Outdoorsman</strong></div></a><a href="https://shop.cbssports.com/partnerid/9571/source/sportsmenu" title="Pro Shop" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Pro Shop</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Weather</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/weather/" title="DFW Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">DFW Weather</strong></div></a><a href="https://dfw.cbslocal.com/100-mile-radius/" title="Live Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Radar</strong></div></a><a href="https://apps.cbslocal.com/weather/dfw/" title="Weather App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a><a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Share Photos" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a><a href="https://dfw.cbslocal.com/cbs-11-storm-chaser/" title="Mobile 11" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Mobile 11</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Best Of</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/best-of/" title="Latest Posts" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest Posts</strong></div></a><a href="https://dfw.cbslocal.com/video/program/1163/" title="Eat · See · Play" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Eat · See · Play</strong></div></a><a href="https://dfw.cbslocal.com/show/fresh-grocer/" title="Fresh Grocer" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Fresh Grocer</strong></div></a><a href="https://dfw.cbslocal.com/category/cares/" title="Community Events" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Community Events</strong></div></a><a href="https://dfw.cbslocal.com/category/plugged-in-to-dfw/" title="Plugged In To DFW" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Plugged In To DFW</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Stations</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/station/cbs-11/" title="About CBS 11" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About CBS 11</strong></div></a><a href="https://dfw.cbslocal.com/station/txa-21/" title="About TXA 21" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">About TXA 21</strong></div></a><a href="https://dfw.cbslocal.com/program-guide/" title="TV Schedules" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">TV Schedules</strong></div></a><a href="https://dfw.cbslocal.com/category/uncategorized/station-contests/" title="Contests" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Contests</strong></div></a><a href="https://dfw.cbslocal.com/contact-cbs-11-txa-21/" title="Contact Us" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://dfw.cbslocal.com/cbsn-live-streaming-video-from-cbs-news/" title="Watch CBSN" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Watch CBSN</strong></div></a><a href="https://apps.cbslocal.com" title="CBS Local App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Local App</strong></div></a><a href="https://dfw.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://cbs.avature.net/cbstvscareers" title="Career Info" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Career Info</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://dfw.cbslocal.com" class="logo"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Dallas / Fort Worth" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=dfw.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-174288" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174288"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-174289" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174289"><a href="http://policies.cbslocal.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-524269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-524269"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-882679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-882679"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-882680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-882680"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-253833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-253833"><a href="https://privacy.cbs/personalizedads">Ad Choices</a></li>
<li id="menu-item-837747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-837747"><a href="http://publicfiles.fcc.gov/tv-profile/ktvt">Public File for KTVT-TV / CBS 11</a></li>
<li id="menu-item-838871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-838871"><a href="http://publicfiles.fcc.gov/tv-profile/ktxa">Public File for KTXA-TV / TXA 21</a></li>
<li id="menu-item-838873" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-838873"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-839598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839598"><a href="https://dfw.cbslocal.com/eeo-reports/">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://dfw.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://dfw.cbslocal.com/_static/??-eJyljEkKgDAMRS9kjKUobsSz1DRooRO20usbxBPo7k/vY8tAKVaOFevBgQvSVsAnMh5dJH9ZiThsbKUprwTvSu3FdvidFy5kQ79+GhtZn9Cc3fl5WsOixknrWelB3TLWUWs=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://dfw.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563381301g' type='text/css' media='all' />
<script>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://dfw.cbslocal.com/_static/??/wp-content/mu-plugins/jetpack/_inc/build/facebook-embed.min.js,/wp-includes/js/wp-embed.min.js?m=1588186636j'></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1'></script>
<script type='text/javascript' src='https://dfw.cbslocal.com/wp-content/mu-plugins/akismet/_inc/form.js?m=1559853159g'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=162246146&postid=907181&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.4.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=a354dff303bfb560c498b3df450ff37198ea7a17#parent=https%3A%2F%2Fdfw.cbslocal.com%2F2020%2F05%2F02%2Fnba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=162246146&postid=907181&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.4.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=a354dff303bfb560c498b3df450ff37198ea7a17#parent=https%3A%2F%2Fdfw.cbslocal.com%2F2020%2F05%2F02%2Fnba-star-bedford-native-myles-turner-donates-50k-to-texas-health-resources%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202018.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'162246146',post:'907181',tz:'-5',srv:'dfw.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246146', '907181' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>