<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://dfw.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="nicholas nelson, bedford, hurst, explosion, dfw news" />
<meta name="keywords" content="nicholas nelson, bedford, hurst, explosion, dfw news" />
<meta property="fb:pages" content="108571612499317" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest &#8211; CBS Dallas / Fort Worth</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Dallas / Fort Worth &raquo; Feed" href="https://dfw.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://dfw.cbslocal.com/_static/??-eJytUMsOwjAM+yFKtCEGF8S3pG0Y1dK06kP7fcrGZSeYxCmJE1t2YI7KBCkkBcqTPGUwOisOBhmcGK72DeUMjxAKpWNrD/ATibwmu3JjIg5ov5Mj19FJBh9s5bbRiXByMiqheZXaIPsF8eOo1f3k5UB5FBwpLTIbRLXUUwlxx49Wjeq1oGPFTqb/uyJuk5Ql793fuqG7XPvzqR9ejM++GA==' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://dfw.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrKEHtR7EWWoMKqRpIRFxe+0C4vXzPlzFYRYjMbCdEingoo4zRga1m6lF1Qa+2CHI51qTKpS4kTNKhaP9eOtC/EYxrXpOk+/GvhuC9+EBIg45Jw==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://dfw.cbslocal.com/_static/??-eJydkt1ywiAQhV+oyGitjhedPssCa6SBLAMb07x9F+PPWDutepGZw4bz7VlAD0lZ6hg71rzDiEVbU1QgC0Gn0De+KzqS64P8OWxQETpoMGtbpDImXM5Evei/QL6zoXe1JJ7BO1SMMQVgLA+aE2S+w/MzedlRZksnymX5QHuMBt3kP0gVfGFlgSFQ8+AYMoW3AdX+9vBO0eVjaDJEtUV0U2yjLtWFWsyi787+K76TaNpI41ZSmgx51IXHgFeOu09PbqxBPt9e1TeQ2KuT7RM5gXTezFY3iC1YNEQ1Vivi6xjrSRpTUomKqN8xT7zoCLmt6Gm/pUD5iff2H5f2mIfs+e7JK+K4rpaP+D5fzdfz1/Vm9fYN0wpoyg==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://dfw.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdtaHBCfGW0mWjJU3Lkg7t95SJA7sNJE5WHNuxoh9J2UgCJFquEIC1vbDCaA1qRxZzVyjPOkWce4dYBUeV553eavSbHAnz4Ih1iF3GsjHdYi6gpuYzYRV9zzDOb9gkUsENoxH4qdMiUMGQGWB8Ra8IVe7dJKavntNnsuIi8T8KAZaJhEvuOZzqQ93um7ptj/4JsLO6Ng=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://dfw.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILephMA6Ib+naqEuVphNJ2e+vQly4sJtlP9uwb0OoYigGtmJBhbDowDV4BpLALXYrK/i4otIbx0IyZr3Av2LnE9fF8yn5c/EyCoynnY1bIlEoNTbuyU4xoX0mvrJPPMvDTffrdJudm/MBCxBU3Q=='></script>
<link rel="https://api.w.org/" href="https://dfw.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dfw.cbslocal.com/wp-json/wp/v2/posts/961337" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dfw.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dfw.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://cbsloc.al/3d5WqRL' />
<link rel="alternate" type="application/json+oembed" href="https://dfw.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdfw.cbslocal.com%2F2021%2F04%2F09%2Fnicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dfw.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdfw.cbslocal.com%2F2021%2F04%2F09%2Fnicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest" /><meta property="og:image" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?w=770" /><meta property="og:image:secure_url" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?w=770" /><meta property="og:image:width" content="770" /><meta property="og:image:height" content="434" /><meta property="og:description" content="Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst." /><meta property="og:type" content="article" /><meta property="og:url" content="https://dfw.cbslocal.com/2021/04/09/nicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest/" /><meta property="article:published_time" content="2021-04-09T18:09:57+00:00" /><meta property="article:suggested-social-copy" content="Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Local,News,Syndicated CBSNDFW,Syndicated Local" /><meta property="article:publisher" content="https://www.facebook.com/CBSDFW" /><meta property="article:author" content="https://www.facebook.com/CBSDFW" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?w=770"><meta name="twitter:title" content="Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest"/><meta name="twitter:description" content="Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst."/><meta name="twitter:site" content="CBSDFW"/>
<link rel="canonical" href="https://dfw.cbslocal.com/2021/04/09/nicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://dfw.cbslocal.com/2021/04/09/nicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/dfw.cbslocal.com","url":"https:\/\/dfw.cbslocal.com","name":"CBS Dallas \/ Fort Worth","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"https:\/\/cbsdfw.com","logo":{"@type":"ImageObject","url":"https:\/\/dfw.cbslocal.com\/wp-content\/uploads\/sites\/15909545\/2018\/05\/4_dallas_cbs11_txa21.png?w=262"}},"url":"https:\/\/dfw.cbslocal.com\/2021\/04\/09\/nicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/dfw.cbslocal.com\/2021\/04\/09\/nicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest\/"},"headline":"Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest","description":"Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst.","image":"https:\/\/dfw.cbslocal.com\/wp-content\/uploads\/sites\/15909545\/2021\/04\/thumbnail_Nicholas-Nelson.jpg?w=770","keywords":["Local","News","Syndicated CBSNDFW","Syndicated Local","Bedford","DFW News","explosion","Hurst","Nicholas Nelson","Jason Allen","news","Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest"],"datePublished":"2021-04-09T18:09:57+00:00","dateModified":"2021-04-09T18:09:57+00:00","author":{"@type":"Person","name":"Jason Allen"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest","description":"Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst.","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/anv-iupl\/18D\/670\/18D670842D7D49CE9CA3152FEE06FEAF.jpg?Expires=1712620800&KeyName=mcpkey1&Signature=lVosGr1bStFW2gWmz46ZY1vvySo","uploadDate":"2021-04-09","duration":"T1M43S","contentUrl":"https:\/\/dfw.cbslocal.com\/video\/5478505-man-arrested-for-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest\/","embedUrl":"https:\/\/dfw.cbslocal.com\/video\/5478505-man-arrested-for-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.DALLAS","news",["manarrestedforbedfordexplosionwasoutofjailafterpreviousexplosivesarrest","post","article","local","news","syndicatedcbsndfw","syndicatedlocal","bedford","dfwnews","explosion","hurst","nicholasnelson","jasonallen","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"local;news;syndicated-cbsndfw;syndicated-local;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2019/07/cropped-dfw-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 9px;
}

.postid-876710 #reptile_30_wrapper {
	display:none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-961337 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"><a href="https://dfw.cbslocal.com/severe-weather/" title="WEATHER" class="cbs-thumbnail-link" ><div class="title-wrapper"><strong class="title">WEATHER</strong><em class="description">Severe Thunderstorm Watch Until 11 P.M. | Alerts | Radar | Forecast | Weather App</em></div></a></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://dfw.cbslocal.com" id="header-logo"><img src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2018/05/4_dallas_cbs11_txa21.png?w=262" alt="CBS Dallas / Fort Worth" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/sports/cowboys/" title="Cowboys" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Cowboys</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/texas-rangers/" title="Rangers" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rangers</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/mavericks/" title="Mavericks" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Mavericks</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/stars/" title="Stars" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Stars</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/fc-dallas/" title="FC Dallas" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">FC Dallas</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/wings/" title="Wings" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Wings</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/golf-sports/" title="Golf" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Golf</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/tennis/" title="Tennis" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Tennis</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/nascar/" title="NASCAR" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NASCAR</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/ufc/" title="UFC" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">UFC</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/college-sports/" title="College Sports" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">College Sports</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/high-school-sports/" title="High School Sports" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">High School Sports</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/video/">Video</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/5478505-man-arrested-for-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest/" title="Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest" class="cbs-thumbnail-link item-1618009740 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/18D/670/18D670842D7D49CE9CA3152FEE06FEAF.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=lVosGr1bStFW2gWmz46ZY1vvySo"></span></div><div class="title-wrapper"><strong class="title">Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest</strong><em class="description">Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst.</em></div><time datetime="2021-04-09T23:09:00+00:00" title="April 9, 2021 at 6:09 pm">7 minutes ago</time></a><a href="https://dfw.cbslocal.com/video/5478463-cbs-11-news-now-friday-evening/" title="CBS 11 News Now: Friday Evening" class="cbs-thumbnail-link item-1618008240 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/84B/B45/84BB4597C67942EE898448501F96C354.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=3bxEP5k5SCmCB0jydruDWHcvSFE"></span></div><div class="title-wrapper"><strong class="title">CBS 11 News Now: Friday Evening</strong><em class="description">Check out what&#039;s making the headlines across North Texas this Friday evening.</em></div><time datetime="2021-04-09T22:44:00+00:00" title="April 9, 2021 at 5:44 pm">32 minutes ago</time></a><a href="https://dfw.cbslocal.com/video/5478399-bitter-political-battle-continues-over-proposed-texas-election-bills/" title="Bitter Political Battle Continues Over Proposed Texas Election Bills" class="cbs-thumbnail-link item-1618006380 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/796/99E/79699EF864AD4533B53B3C4F5389F6FB.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=qAL1gyKQO7IajNJm3ioLq0NnbxM"></span></div><div class="title-wrapper"><strong class="title">Bitter Political Battle Continues Over Proposed Texas Election Bills</strong><em class="description">This week, a House elections-related bill passed in committee and will now head to the full House for consideration. This comes as the bitter political battle over this legislation and a similar Senate bill escalates.</em></div><time datetime="2021-04-09T22:13:00+00:00" title="April 9, 2021 at 5:13 pm">1 hour ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="https://dfw.cbslocal.com/category/politics/" title="Politics" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://dfw.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://dfw.cbslocal.com/category/news/consumer/" title="Consumer" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Consumer</strong></div></a><a href="https://dfw.cbslocal.com/category/news/education/" title="Education" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Education</strong></div></a><a href="https://dfw.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://dfw.cbslocal.com/category/news/tech/" title="Tech" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Tech</strong></div></a><a href="https://dfw.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://dfw.cbslocal.com/category/autos" title="Autos" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Autos</strong></div></a><a href="https://dfw.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="https://dfw.cbslocal.com/category/investigators/" title="The I-Team" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">The I-Team</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/04/09/nicholas-nelson-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest/" title="Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest" class="cbs-thumbnail-link item-1618009797 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest</strong><em class="description">Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst.</em></div></a><a href="https://dfw.cbslocal.com/2021/04/09/texas-gop-chair-allen-west-champions-election-bills-opponents-increase-efforts-against-them/" title="Texas GOP Chair Allen West Champions Election Bills As Opponents Increase Efforts Against Them" class="cbs-thumbnail-link item-1618007136 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/79699EF864AD4533B53B3C4F5389F6FB.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Texas GOP Chair Allen West Champions Election Bills As Opponents Increase Efforts Against Them</strong><em class="description">Civil rights and community organizations and prominent Texas Democrats are increasing their campaign against two controversial Texas election bills -- Senate Bill 7 and House Bill 6.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Featured Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/video/category/news/" title="News Video" class="cbs-thumbnail-link item-1479855909" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_news_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News Video</strong></div></a><a href="http://dfw.cbslocal.com/video/category/news-weather/" title="Weather Video" class="cbs-thumbnail-link item-1479855854" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Video</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/weather/" title="DFW Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">DFW Weather</strong></div></a><a href="https://dfw.cbslocal.com/100-mile-radius/" title="Live Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Radar</strong></div></a><a href="http://apps.cbslocal.com/weather/dfw/" title="Weather App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a><a href="https://dfw.cbslocal.com/category/gardening-101-section/" title="Gardening 101" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Gardening 101</strong></div></a><a href="https://dfw.cbslocal.com/school-closings/" title="Closings/Cancellations" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Closings/Cancellations</strong></div></a><a href="https://dfw.cbslocal.com/cbs-11-storm-chaser/" title="Mobile 11" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Mobile 11</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Forecast</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/5478348-erin-morans-weather-update/" title="Erin Moran&#039;s Weather Update" class="cbs-thumbnail-link item-1618005300 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/EB4/BC4/EB4BC4EB0D5845BEA4EB55E636362356.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=p-JfoLKAAnPSVHEd4lM-ndEk2qw"></span></div><div class="title-wrapper"><strong class="title">Erin Moran&#039;s Weather Update</strong><em class="description">Severe Thunderstorm Watch in effect for much of North Texas until 11 p.m. Friday.</em></div><time datetime="2021-04-09T21:55:00+00:00" title="April 9, 2021 at 4:55 pm">1 hour ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Stories</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/04/08/sunny-weather-short-lived-in-north-texas-as-possible-weekend-storm-approaches/" title="Sunny Weather Short-Lived In North Texas As Possible Weekend Storm Approaches" class="cbs-thumbnail-link item-1617904922 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_FRIDAY.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sunny Weather Short-Lived In North Texas As Possible Weekend Storm Approaches</strong><em class="description">Today&#039;s beautiful, sunny weather will be short-lived as our next storm system approaches on Friday.</em></div></a><a href="https://dfw.cbslocal.com/2021/04/06/wind-advisory-in-north-texas-until-midnight-tuesday-night/" title="Wind Advisory In North Texas Until Midnight Tuesday Night" class="cbs-thumbnail-link item-1617733326 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/wind-gusts.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Wind Advisory In North Texas Until Midnight Tuesday Night</strong><em class="description">It&#039;s a humid blustery day in North Texas. Strong winds out of the south will continue to gust close to 40 MPH Tuesday and Tuesday night.</em></div></a><a href="https://dfw.cbslocal.com/2021/03/25/111-deaths-texas-winter-storms-febraury/" title="111 Deaths Now Attributed To Texas&#039; Winter Storms In February" class="cbs-thumbnail-link item-1616705455 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/02/GettyImages-1231207589.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">111 Deaths Now Attributed To Texas&#039; Winter Storms In February</strong><em class="description">The majority of verified deaths were associated with hypothermia, DSHS said Thursday.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/">All Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/sports/cowboys/" title="Cowboys" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Cowboys</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/texas-rangers/" title="Rangers" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rangers</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/mavericks/" title="Mavericks" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Mavericks</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/stars/" title="Stars" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Stars</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/fc-dallas/" title="FC Dallas" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">FC Dallas</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/wings/" title="Wings" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Wings</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/golf-sports/" title="Golf" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Golf</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/tennis/" title="Tennis" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Tennis</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/nascar/" title="NASCAR" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NASCAR</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/ufc/" title="UFC" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">UFC</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/college-sports/" title="College Sports" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">College Sports</strong></div></a><a href="https://dfw.cbslocal.com/category/sports/high-school-sports/" title="High School Sports" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">High School Sports</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/cowboys/">Cowboys</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/03/25/cowboys-dl-tyrone-crawford-to-retire-after-9-seasons/" title="Cowboys DL Tyrone Crawford To Retire After 9 Seasons" class="cbs-thumbnail-link item-1616696854 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/03/GettyImages-492302908.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Cowboys DL Tyrone Crawford To Retire After 9 Seasons</strong><em class="description">After nine seasons in the NFL and with the Dallas Cowboys, defensive lineman Tyrone Crawford is headed for retirement.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/texas-rangers/">Rangers</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/04/07/dallas-stars-rally-three-goal-deficit-fall-short-lose-blackhawks/" title="Dallas Stars Rally From Three-Goal Deficit But Still Fall Short, Lose To Blackhawks 4-2" class="cbs-thumbnail-link item-1617797722 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/Dallas-Stars.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Dallas Stars Rally From Three-Goal Deficit But Still Fall Short, Lose To Blackhawks 4-2</strong><em class="description">The Dallas Stars rallied from a three-goal deficit in the third period, but Blackhawks goaltender Kevin Lankinen stopped Dallas’ Roope Hintz in the slot with 93 seconds to play.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/mavericks/">Mavericks</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/04/09/comeback-luka-porzingis-dallas-mavericks-over-bucks/" title="It&#039;s Okay To Call It A Comeback -- Luka, Porzingis Spring Dallas Mavericks Over Bucks 116-101" class="cbs-thumbnail-link item-1617965740 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/Mavericks.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">It&#039;s Okay To Call It A Comeback -- Luka, Porzingis Spring Dallas Mavericks Over Bucks 116-101</strong><em class="description">The team was still stinging from a loss against an in-state opponent and one of the worst in the league, so Kristaps Porzingis got two quick shots on purpose and another by accident in the fourth quarter while putting Dallas in front of Milwaukee.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/sports/stars/">Stars</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/04/04/stars-coach-rick-bowness-leaves-mid-game-covid-19-protocols/" title="Stars Coach Rick Bowness Leaves Mid-Game Due To COVID-19 Protocols" class="cbs-thumbnail-link item-1617586050 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/GettyImages-1297978811.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Stars Coach Rick Bowness Leaves Mid-Game Due To COVID-19 Protocols</strong><em class="description">Dallas Stars coach Rick Bowness didn’t return to the bench for the third period of Sunday night’s game against the Carolina Hurricanes due to COVID protocols.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://dfw.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Featured Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/video/category/news/" title="News Video" class="cbs-thumbnail-link item-1479855909" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_news_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News Video</strong></div></a><a href="http://dfw.cbslocal.com/video/category/news-weather/" title="Weather Video" class="cbs-thumbnail-link item-1479855854" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Video</strong></div></a><a href="http://dfw.cbslocal.com/video/category/sports/" title="Sports" class="cbs-thumbnail-link item-1479769606" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2016/03/category_sports_2_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sports</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/5478505-man-arrested-for-bedford-explosion-was-out-of-jail-after-previous-explosives-arrest/" title="Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest" class="cbs-thumbnail-link item-1618009740 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/18D/670/18D670842D7D49CE9CA3152FEE06FEAF.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=lVosGr1bStFW2gWmz46ZY1vvySo"></span></div><div class="title-wrapper"><strong class="title">Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest</strong><em class="description">Nicholas Nelson was arrested in connection to an explosion in Bedford this week. He had been jailed and released in February for possessing components of an explosive in Hurst.</em></div><time datetime="2021-04-09T23:09:00+00:00" title="April 9, 2021 at 6:09 pm">7 minutes ago</time></a><a href="https://dfw.cbslocal.com/video/5478399-bitter-political-battle-continues-over-proposed-texas-election-bills/" title="Bitter Political Battle Continues Over Proposed Texas Election Bills" class="cbs-thumbnail-link item-1618006380 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/796/99E/79699EF864AD4533B53B3C4F5389F6FB.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=qAL1gyKQO7IajNJm3ioLq0NnbxM"></span></div><div class="title-wrapper"><strong class="title">Bitter Political Battle Continues Over Proposed Texas Election Bills</strong><em class="description">This week, a House elections-related bill passed in committee and will now head to the full House for consideration. This comes as the bitter political battle over this legislation and a similar Senate bill escalates.</em></div><time datetime="2021-04-09T22:13:00+00:00" title="April 9, 2021 at 5:13 pm">1 hour ago</time></a><a href="https://dfw.cbslocal.com/video/5478388-some-boeing-737-max-jets-grounded-by-american-southwest-airlines-due-to-electrical-issues/" title="Some Boeing 737 Max Jets Grounded By American, Southwest Airlines Due To Electrical Issues" class="cbs-thumbnail-link item-1618006140 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/4BA/493/4BA4936C72E2409CBC42A4FE2ECA8871.jpg?Expires=1712620800&#038;KeyName=mcpkey1&#038;Signature=U9r4GeX-wE1_Y_wrvUCg9HOMBUQ"></span></div><div class="title-wrapper"><strong class="title">Some Boeing 737 Max Jets Grounded By American, Southwest Airlines Due To Electrical Issues</strong><em class="description">In all, U.S. airlines temporarily suspended the use of more than 65 Boeing 737 MAX jets, with 16 carriers.</em></div><time datetime="2021-04-09T22:09:00+00:00" title="April 9, 2021 at 5:09 pm">1 hour ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/best-of" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/best-of">Best Of</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2020/11/23/free-limited-public-wi-fi-coming-to-some-low-income-fort-worth-neighborhoods/" title="Free Limited Public Wi-Fi Coming To Some Low Income Fort Worth Neighborhoods" class="cbs-thumbnail-link item-1606152095 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/11/Fort-Worth-Internet-web.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Free Limited Public Wi-Fi Coming To Some Low Income Fort Worth Neighborhoods</strong><em class="description">Officials said crews will begin installing equipment in the Rosemont area the week after Thanksgiving.</em></div></a><a href="https://dfw.cbslocal.com/2020/10/29/police-called-bloody-dallas-halloween-decorations/" title="Police Called On Bloody East Dallas Halloween Decorations" class="cbs-thumbnail-link item-1603994497 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/10/East-Dallas-Halloween-Display.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Police Called On Bloody East Dallas Halloween Decorations</strong><em class="description">Artist Steven Novak says he &quot;loves gore,&quot; but Halloween -- not so much. Tell that to his East Dallas neighbors who called the cops about his bloody decorations.</em></div></a><a href="https://dfw.cbslocal.com/2020/10/24/texas-singer-songwriter-self-professed-gypsy-songman-jerry-jeff-walker-dead-at-78/" title="Texas Singer, Songwriter, Self-Professed Gypsy Songman Jerry Jeff Walker Dead At 78: &#039;Sad Day For Texas&#039;" class="cbs-thumbnail-link item-1603575059 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/10/Jerry-Jeff-Walker-Getty.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Texas Singer, Songwriter, Self-Professed Gypsy Songman Jerry Jeff Walker Dead At 78: &#039;Sad Day For Texas&#039;</strong><em class="description">Jerry Jeff Walker, perhaps most noted around the world as the man who penned pop and country hit &quot;Mr. Bojangles&quot; has died at the age of 78.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/video/program/1163/">E.S.P Video</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/03/25/eat-see-play-hometown-tourist/" title="Eat See Play: Hometown Tourist" class="cbs-thumbnail-link item-1616707360 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/03/esp-tourist-thumb.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Eat See Play: Hometown Tourist</strong></div></a><a href="https://dfw.cbslocal.com/2020/10/20/praising-the-love-of-bbq-at-meat-church/" title="Praising the love of BBQ at Meat Church" class="cbs-thumbnail-link item-1603206142 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/10/meat-thumb-3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Praising the love of BBQ at Meat Church</strong></div></a><a href="https://dfw.cbslocal.com/2020/09/21/eat-see-play-dallas-taco-tour/" title="Eat See Play Dallas Taco Tour" class="cbs-thumbnail-link item-1600714913 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/09/taco-thumb.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Eat See Play Dallas Taco Tour</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-link w-submenu"><a href="https://dfw.cbslocal.com/category/uncategorized/station-contests/" title="Contests &amp; More" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/station/cbs-11/" title="CBS 11 / News Team" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBS 11 / News Team</strong></div></a><a href="https://dfw.cbslocal.com/station/txa-21/" title="TXA 21" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">TXA 21</strong></div></a><a href="https://dfw.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://dfw.cbslocal.com/category/links-numbers/" title="Links &amp; Numbers" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Links &amp; Numbers</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Upload Images/Video" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Upload Images/Video</strong></div></a><a href="https://dfw.cbslocal.com/photo-galleries/" title="Photo Galleries" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Photo Galleries</strong></div></a><a href="https://dfw.cbslocal.com/category/uncategorized/station-contests/" title="Contests" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contests</strong></div></a><a href="https://dfw.cbslocal.com/category/uncategorized/station-events/" title="Station Events" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Station Events</strong></div></a><a href="https://dfw.cbslocal.com/category/cares/" title="Community Events" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Community Events</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/dfw-outdoorsman/">DFW Outdoorsman</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/video/program/694/" title="Video" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><a href="https://dfw.cbslocal.com/outfitters/" title="Outfitters" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Outfitters</strong></div></a><a href="https://dfw.cbslocal.com/piece-of-texas/" title="Financing Your Piece of Texas" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Financing Your Piece of Texas</strong></div></a><a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Share Photos" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://dfw.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/2021/03/10/galveston-prepping-for-spring-breakers-covid-19-restrictions-relax/" title="Galveston Prepping For Spring Breakers As COVID-19 Restrictions Relax" class="cbs-thumbnail-link item-1615398882 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/03/Screenshot-2021-03-10-115107.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Galveston Prepping For Spring Breakers As COVID-19 Restrictions Relax</strong><em class="description">Officials in Galveston are getting ready for an influx in visits this month while travelers are deciding how they want to approach guidelines against COVID-19.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://dfw.cbslocal.com/cbs-11-storm-chaser/" title="CBS 11 Storm Chaser" class="cbs-thumbnail-link item-1525296685" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2018/05/unknown2.jpeg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS 11 Storm Chaser</strong></div></a><a href="http://dfw.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1519414047" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2018/02/CBS.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<a id="live" class="v2" href="https://dfw.cbslocal.com/live/" data-source_url="https://feeds-cbsn.cbsnews.com/2.0/rundown/?edition=CBSN-DAL&#038;partner=cbsnsite"><span class="button"><strong>CBSN Dallas - Ft. Worth</strong><em>Watch Now</em></span></a>
	<a href="http://dfw.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="32.899809" longitude="-97.040335" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://dfw.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Man Arrested For Bedford Explosion Was Out Of Jail After Previous Explosives Arrest</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-personality">By <a href="https://dfw.cbslocal.com/personality/jason-allen">Jason Allen</a></span><time class="post-date">April 9, 2021 at 6:09 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://dfw.cbslocal.com/tag/bedford/">Bedford</a>, <a href="https://dfw.cbslocal.com/tag/dfw-news/">DFW News</a>, <a href="https://dfw.cbslocal.com/tag/explosion/">explosion</a>, <a href="https://dfw.cbslocal.com/tag/hurst/">Hurst</a>, <a href="https://dfw.cbslocal.com/tag/nicholas-nelson/">Nicholas Nelson</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5478505","autoplay":true,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"Dallas.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"https:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.DALLAS&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=https:\/\/dfw.cbslocal.com&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}},"moat":{"clientSide":{"partnerCode":"cbslocalanvatovideo181732609431"}}},"shareLink":"https:\/\/cbsloc.al\/3d5WqRL","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div id="article-livedvr-block" class="embed-item embed-ottplayer" ><div class="wrapper">
<span class="adhesive-wrapper"><div class="logo-container"><a href="https://dfw.cbslocal.com/live/cbsn-dfw/"><img src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2012/03/CBSN-WHITE-H-DallasFtW.png?w=420"/></a></div></span><div class="dvr-container"><div class="dvr-wrapper embed-item embed-slider w-action-manual" data-up_url="https://feeds-cbsn.cbsnews.com/2.0/rundown/?edition=CBSN-DAL&#038;partner=cbsnsite" data-channel_slug="cbsn-dfw" data-w-live="true" data-dvr-live-title="CBSN DFW" data-dvr-live-thumb_url="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/05/Dallas-WatchLive.png?w=310&#038;h=174&#038;crop=1"></div></div><script>jQuery(function($){jQuery(window).load(function(){cbs_embed_ottplayer.update_dvr("#article-livedvr-block .dvr-container .dvr-wrapper");setInterval(function(){cbs_embed_ottplayer.update_dvr("#article-livedvr-block .dvr-container .dvr-wrapper");},30000);});});</script>
</div></div><div class="main-story-wrapper"><p><strong>BEDFORD, Texas (CBSDFW.COM) &#8211;</strong> The man arrested in connection with an explosion in Bedford this week was released from jail in February for possessing components of an explosive in an apartment in Hurst.</p>
<p>Investigators suspect Nicholas Nelson had also been posting videos of his bombs on YouTube over the past year, including test explosions and walkthroughs of his manufacturing process.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://dfw.cbslocal.com/2021/04/09/texas-gop-chair-allen-west-champions-election-bills-opponents-increase-efforts-against-them/" target="_blank">Texas GOP Chair Allen West Champions Election Bills As Opponents Increase Efforts Against Them</a>
<p>In a statement online Friday identifying the 37-year-old as the person arrested for the explosion this week, Bedford police wrote they were still confident the explosion this week was an isolated incident.</p>
<div id="attachment_961339" style="width: 560px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-961339" loading="lazy" class=" wp-image-961339" src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?w=300" alt="" width="550" height="310" srcset="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg 770w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=150,85 150w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=300,169 300w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=768,433 768w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=640,361 640w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=310,174 310w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=320,180 320w, https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_Nicholas-Nelson.jpg?resize=620,349 620w" sizes="(max-width: 550px) 100vw, 550px" /><p id="caption-attachment-961339" class="wp-caption-text">Nicholas Nelson mugshot (Source: Bedford Police Department)</p></div>
<p>Hurst police referred questions on the case to the FBI, which is working with local investigators on the case.</p>
<p>Witnesses to the explosion in a drainage culvert on Forest Ridge Drive Wednesday said police appeared to have an idea who they were looking for within an hour or so after the incident.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://dfw.cbslocal.com/2021/04/09/dallas-neighborhood-welcomes-pop-up-mobile-food-park/" target="_blank">Dallas Neighborhood Welcomes Pop-Up Mobile Food Park</a>
<p>Nelson had been arrested Feb. 18 after a tip to Hurst police that he was making explosives in an apartment.</p>
<p>The same informant showed police a YouTube page they said was run by Nelson, that includes dozens of videos of testing explosives and information on how he is building devices.</p>
<p>Police acted quickly to detain Nelson at the time, noting the urgency in a search warrant for the apartment. Some people in the area evacuated at the time as police moved some of the materials out of the building.</p>
<p>Nelson was arrested, but court records show he posted an $8,500 bond for the explosives charge and a drug charge and was released three days later.</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://dfw.cbslocal.com/2021/04/09/man-accused-of-murdering-another-during-dispute-in-grand-prairie-neighborhood/" target="_blank">Man Accused Of Murdering Another During Dispute In Grand Prairie Neighborhood</a>
<p>After the explosion this week, police found a second device that they disposed of in a controlled detonation. A SWAT team later arrested Nelson in an apartment just a couple blocks away. A man at the apartment Friday said he had no comment on the case.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3d5WqRL"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3d5WqRL"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3d5WqRL"></a></span>
			</div>
		
			</div>
</div></div></div><div id="app-promo-wrapper"><a href="https://apps.cbslocal.com/dfw/" data-ios="https://apps.apple.com/us/app/cbs-dfw/id1511234492" data-android="https://play.google.com/store/apps/details?id=com.ktvt.android.news" target="_blank"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/app-promos/dfw.jpg"/></a></div><div id="personality-credits-container" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>Jason </span> Allen</h4></header><div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" id="personality-credits" data-social-links="{&quot;twitter_url&quot;:&quot;http:\/\/www.twitter.com\/CBS11JasonAllen&quot;,&quot;facebook_url&quot;:&quot;https:\/\/www.facebook.com\/jasonallentv&quot;,&quot;email_address&quot;:&quot;jmallen@cbs.com&quot;}" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2011/05/jason-allen_cbsdfw.jpg?w=625&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><em class="description"><a href="https://dfw.cbslocal.com/personality/jason-allen/" id="more-from-personality"><span>More from</span> <strong>Jason Allen</strong></a></em></div></div></div>
</div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSDFW" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/#!/CBSDFW" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="https://www.youtube.com/user/CBSDFW/videos" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.instagram.com/CBSDFW/" target="_blank" title="instagram_url" class="cbs-thumbnail-link instagram_url" ><div class="title-wrapper"><strong class="title">instagram_url</strong></div></a><a href="https://www.reddit.com/user/cbs11dfw/" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/ktvt-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=dfw"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://dfw.cbslocal.com/2021/04/07/viewers-north-texas-report-seeing-lights-sky/" title="Viewers In North Texas Report Seeing Mysterious Streak Of Lights In Sky" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/Screenshot-2021-04-07-215445.jpg?resize=55%2C55&#038;ssl=1" alt="Viewers In North Texas Report Seeing Mysterious Streak Of Lights In Sky" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/07/viewers-north-texas-report-seeing-lights-sky/" title="Viewers In North Texas Report Seeing Mysterious Streak Of Lights In Sky" class="bump-view" data-bump-view="tp">Viewers In North Texas Report Seeing Mysterious Streak Of Lights In Sky</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/09/boeing-737-max-electrical-issue-grounds-planes-american-southwest/" title="New Boeing 737 Max Electrical Issue Grounds Planes With Both American, Southwest Airlines" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2020/04/Southwest-Air-and-American-Air.jpg?resize=55%2C55&#038;ssl=1" alt="New Boeing 737 Max Electrical Issue Grounds Planes With Both American, Southwest Airlines" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/09/boeing-737-max-electrical-issue-grounds-planes-american-southwest/" title="New Boeing 737 Max Electrical Issue Grounds Planes With Both American, Southwest Airlines" class="bump-view" data-bump-view="tp">New Boeing 737 Max Electrical Issue Grounds Planes With Both American, Southwest Airlines</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/07/dallas-sheriffs-clerk-supervisor-umeka-t-myers-arrested-alleged-theft/" title="Dallas Sheriff’s Clerk Supervisor Umeka T. Myers Arrested After Alleged Theft" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/Umeka.jpg?resize=55%2C55&#038;ssl=1" alt="Dallas Sheriff’s Clerk Supervisor Umeka T. Myers Arrested After Alleged Theft" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/07/dallas-sheriffs-clerk-supervisor-umeka-t-myers-arrested-alleged-theft/" title="Dallas Sheriff’s Clerk Supervisor Umeka T. Myers Arrested After Alleged Theft" class="bump-view" data-bump-view="tp">Dallas Sheriff’s Clerk Supervisor Umeka T. Myers Arrested After Alleged Theft</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/07/siblings-arrested-crash-frisco-killed-2-elderly-victims/" title="Siblings Arrested For Crash In Frisco That Killed 2 Elderly Victims" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/thumbnail_walker.jpg?resize=55%2C55&#038;ssl=1" alt="Siblings Arrested For Crash In Frisco That Killed 2 Elderly Victims" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/07/siblings-arrested-crash-frisco-killed-2-elderly-victims/" title="Siblings Arrested For Crash In Frisco That Killed 2 Elderly Victims" class="bump-view" data-bump-view="tp">Siblings Arrested For Crash In Frisco That Killed 2 Elderly Victims</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/05/allen-murder-suicide-pact-social-media/" title="Allen Police Find 6 Dead, Say Suicide Pact Shared On Social Media Mentions &#039;Killing Family&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/allen-suicide-1.jpg?resize=55%2C55&#038;ssl=1" alt="Allen Police Find 6 Dead, Say Suicide Pact Shared On Social Media Mentions &#039;Killing Family&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/05/allen-murder-suicide-pact-social-media/" title="Allen Police Find 6 Dead, Say Suicide Pact Shared On Social Media Mentions &#039;Killing Family&#039;" class="bump-view" data-bump-view="tp">Allen Police Find 6 Dead, Say Suicide Pact Shared On Social Media Mentions &#039;Killing Family&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/09/stimulus-check-update-fourth-relief-payment-covid/" title="Stimulus Check Update: Should You Expect A Fourth Relief Payment?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/joe-biden-1.jpg?resize=55%2C55&#038;ssl=1" alt="Stimulus Check Update: Should You Expect A Fourth Relief Payment?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/09/stimulus-check-update-fourth-relief-payment-covid/" title="Stimulus Check Update: Should You Expect A Fourth Relief Payment?" class="bump-view" data-bump-view="tp">Stimulus Check Update: Should You Expect A Fourth Relief Payment?</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/07/ayanna-williams-worlds-longest-nails-cuts-them-fort-worth-after-30-years/" title="Woman With World&#039;s Longest Nails Cuts Them In Fort Worth After Nearly 30 Years" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/GettyImages-459232808.jpg?resize=55%2C55&#038;ssl=1" alt="Woman With World&#039;s Longest Nails Cuts Them In Fort Worth After Nearly 30 Years" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/07/ayanna-williams-worlds-longest-nails-cuts-them-fort-worth-after-30-years/" title="Woman With World&#039;s Longest Nails Cuts Them In Fort Worth After Nearly 30 Years" class="bump-view" data-bump-view="tp">Woman With World&#039;s Longest Nails Cuts Them In Fort Worth After Nearly 30 Years</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/08/1-dead-5-injured-shooting-bryan-texas-suspect-larry-bollin/" title="1 Dead, 5 Injured In Shooting At Business In Bryan, Texas, Suspect Identified As Employee Larry Bollin" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/download-2-3.png?resize=55%2C55&#038;ssl=1" alt="1 Dead, 5 Injured In Shooting At Business In Bryan, Texas, Suspect Identified As Employee Larry Bollin" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/08/1-dead-5-injured-shooting-bryan-texas-suspect-larry-bollin/" title="1 Dead, 5 Injured In Shooting At Business In Bryan, Texas, Suspect Identified As Employee Larry Bollin" class="bump-view" data-bump-view="tp">1 Dead, 5 Injured In Shooting At Business In Bryan, Texas, Suspect Identified As Employee Larry Bollin</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/09/dallas-police-arrest-sebastian-acosta-animal-cruelty-2-puppies-dead/" title="Dallas Police Arrest Sebastian Acosta In Animal Cruelty Case That Left 2 Puppies Dead" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2021/04/Acosta-1.jpg?resize=55%2C55&#038;ssl=1" alt="Dallas Police Arrest Sebastian Acosta In Animal Cruelty Case That Left 2 Puppies Dead" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/09/dallas-police-arrest-sebastian-acosta-animal-cruelty-2-puppies-dead/" title="Dallas Police Arrest Sebastian Acosta In Animal Cruelty Case That Left 2 Puppies Dead" class="bump-view" data-bump-view="tp">Dallas Police Arrest Sebastian Acosta In Animal Cruelty Case That Left 2 Puppies Dead</a>
							</div>
													</li>
										<li>
						<a href="https://dfw.cbslocal.com/2021/04/07/kids-killed-denton-county-dumped-backhoe-bucket-run-over/" title="Kids, Ages 11 &amp; 7, Killed In Denton County After Being Dumped From Backhoe Bucket And Run Over" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/dfw.cbslocal.com/wp-content/uploads/sites/15909545/2015/10/caution-tape.jpg?resize=55%2C55&#038;ssl=1" alt="Kids, Ages 11 &amp; 7, Killed In Denton County After Being Dumped From Backhoe Bucket And Run Over" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://dfw.cbslocal.com/2021/04/07/kids-killed-denton-county-dumped-backhoe-bucket-run-over/" title="Kids, Ages 11 &amp; 7, Killed In Denton County After Being Dumped From Backhoe Bucket And Run Over" class="bump-view" data-bump-view="tp">Kids, Ages 11 &amp; 7, Killed In Denton County After Being Dumped From Backhoe Bucket And Run Over</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://dfw.cbslocal.com" class="logo"><img src="https://dfw.cbslocal.com/wp-content/uploads/sites/15909545/2017/10/dfw.png" alt="CBS Dallas / Fort Worth" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSDFW" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/#!/CBSDFW" class="twitter" target="_blank">Twitter</a><a href="https://www.youtube.com/user/CBSDFW/videos" class="youtube" target="_blank">YouTube</a><a href="https://www.instagram.com/CBSDFW/" class="instagram" target="_blank">Instagram</a><a href="https://www.reddit.com/user/cbs11dfw/" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/ktvt-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/news/" title="Dallas News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Dallas News</strong></div></a><a href="https://dfw.cbslocal.com/tag/dfw-news/" title="DFW News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">DFW News</strong></div></a><a href="https://dfw.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><a href="https://dfw.cbslocal.com/photo-galleries/" title="Photo Galleries" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Photo Galleries</strong></div></a><a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Share Photos" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a><a href="https://dfw.cbslocal.com/category/links-numbers/" title="Links &amp; Numbers" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Links &amp; Numbers</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/sports/" title="Dallas Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Dallas Sports</strong></div></a><a href="https://sports.cbslocal.com" title="CBS Local Sports" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBS Local Sports</strong></div></a><a href="https://dfw.cbslocal.com/the-landry-award/" title="The Landry Award" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">The Landry Award</strong></div></a><a href="https://dfw.cbslocal.com/category/dfw-outdoorsman/" title="DFW Outdoorsman" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">DFW Outdoorsman</strong></div></a><a href="https://shop.cbssports.com/partnerid/9571/source/sportsmenu" title="Pro Shop" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Pro Shop</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Weather</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/weather/" title="DFW Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">DFW Weather</strong></div></a><a href="https://dfw.cbslocal.com/100-mile-radius/" title="Live Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Radar</strong></div></a><a href="https://apps.cbslocal.com/weather/dfw/" title="Weather App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a><a href="https://dfw.cbslocal.com/track-the-heat/" title="Track The Heat" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Track The Heat</strong></div></a><a href="https://dfw.cbslocal.com/your-photos-cbs-dfw/" title="Share Photos" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a><a href="https://dfw.cbslocal.com/cbs-11-storm-chaser/" title="Mobile 11" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Mobile 11</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Best Of</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/best-of/" title="Latest Posts" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest Posts</strong></div></a><a href="https://dfw.cbslocal.com/video/program/1163/" title="Eat · See · Play" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Eat · See · Play</strong></div></a><a href="https://dfw.cbslocal.com/show/fresh-grocer/" title="Fresh Grocer" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Fresh Grocer</strong></div></a><a href="https://dfw.cbslocal.com/category/cares/" title="Community Events" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Community Events</strong></div></a><a href="https://dfw.cbslocal.com/category/plugged-in-to-dfw/" title="Plugged In To DFW" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Plugged In To DFW</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Stations</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/station/cbs-11/" title="About CBS 11" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About CBS 11</strong></div></a><a href="https://dfw.cbslocal.com/station/txa-21/" title="About TXA 21" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">About TXA 21</strong></div></a><a href="https://dfw.cbslocal.com/program-guide/" title="TV Schedules" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">TV Schedules</strong></div></a><a href="https://dfw.cbslocal.com/category/uncategorized/station-contests/" title="Contests" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Contests</strong></div></a><a href="https://dfw.cbslocal.com/contact-cbs-11-txa-21/" title="Contact Us" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://dfw.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://dfw.cbslocal.com/cbsn-live-streaming-video-from-cbs-news/" title="Watch CBSN" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Watch CBSN</strong></div></a><a href="https://apps.cbslocal.com" title="CBS Local App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Local App</strong></div></a><a href="https://dfw.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://cbs.avature.net/cbstvscareers" title="Career Info" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Career Info</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://dfw.cbslocal.com" class="logo"><img src="https://dfw.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Dallas / Fort Worth" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=dfw.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-174288" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174288"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-174289" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174289"><a href="http://policies.cbslocal.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-524269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-524269"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-882679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-882679"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-882680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-882680"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-253833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-253833"><a href="https://privacy.cbs/personalizedads">Ad Choices</a></li>
<li id="menu-item-837747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-837747"><a href="http://publicfiles.fcc.gov/tv-profile/ktvt">Public File for KTVT-TV / CBS 11</a></li>
<li id="menu-item-838871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-838871"><a href="http://publicfiles.fcc.gov/tv-profile/ktxa">Public File for KTXA-TV / TXA 21</a></li>
<li id="menu-item-838873" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-838873"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-935827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-935827"><a href="https://dfw.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-839598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839598"><a href="https://dfw.cbslocal.com/eeo-reports/">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://dfw.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://dfw.cbslocal.com/_static/??-eJylj1EKgCAQRC+UrQnVV3QW06WEVaPdkG6fRCeov2He8GCg7MrlJJgEZMOIDG5hRdlZgpAcnb5WGBf0lfAbVUFb14cqwa8obQUNfDMxBY/HH0MW2cle/yQU+Lkxx6kbutFobUx/A8YAaSg=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://dfw.cbslocal.com/_static/??-eJx9jE0KhDAMhS9kjRbUlXgWTYNW0rQ0LXP9qTAwO1eP9/fBJxmMUkgKlIsCKeChhiPuDF6Qq2vRraCJvaOftEumPnjpUbWDN0bienpRCNFVbk3acxHKbaJ/82C2sI7zuNhhsHb6At5CN2k=' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://dfw.cbslocal.com/_static/??/wp-content/mu-plugins/jetpack-9.6/_inc/build/facebook-embed.min.js,/wp-includes/js/wp-embed.min.js?m=1617137966j'></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1' id='cbs-weather-widget-js'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7' id='cbs-cbs-anvato-js'></script>
<script type='text/javascript' src='https://dfw.cbslocal.com/_static/??-eJylzEsKgDAMBNALWaMFdSWeRduALekHExFv7wdxLbiaYWAebFmZFAWjgMwYkMFMrCiZkcBFQ6s9J8/AmZzFJ8rgYum5gE9vDBPaG7mb4otY/hlJJNO4v8wQ+rqtO11VWjf+AJRDTkA='></script>
<script src='https://stats.wp.com/e-202114.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6',blog:'162246146',post:'961337',tz:'-5',srv:'dfw.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246146', '961337' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>